Running Magic Online on a Mac

  • #1
    So, I've decided to bite the bullet and install Parallels in order to run Magic Online on my Mac. I had no issues installing the program or Windows XP to run Magic Online, and I installed and updated the program successfully. However, after all of that, every time I launch MODO, it crashes before it can even start up. I attempted to repair the launch client, but that did not fix the problem. I also downloaded the most recent version of Direct X and tried reinstalling the actual program. Nothing has worked so far and it is still crashing immediately after I click launch. I was wondering if anyone has had this problem and knows how to fix it? Your help is GREATLY appreciated. Thank you in advance!
  • #2
    I can't comment on Parallels, but I use to run MTGO using a virtual windows xp on a linux machine using Oracle Virtualbox (www.virtualbox.org) and it ran well. I ended up going to a dual boot, because everytime my linux updated, it was a pain to update the virtualbox software. It was free for linux, but I also think it's free for the Mac, so it can't hurt to try, assuming you have a few hours to figure it out, install windows, then install MTGO, update the Direct X, get the latest .net framework. Oh, by the way, do you have the right version of .net installed? That might be what's messing up your parrallels install.
  • #3
    What is .net ? How would I check?
  • #4
    Quote from rytrepanier
    What is .net ? How would I check?


    I believe it's a microsoft application that MTGO uses somehow. You could get it here: http://www.microsoft.com/net. I don't recall how to check which version you have and whether its compatible with MTGO, but if there's any doubt I would try the latest version and hope for the best.

    There's some dated, but still usefull, discussion here: http://forums.mtgsalvation.com/showthread.php?t=316831

    Edit: OK, you could just go to your add/remove programs and see if it's installed, and which version. I have version 4.0.30319, and it works. But again, the newer one probably works fine and is easier than trying to get an older version.
    Last edited by rurodrig: 3/12/2013 7:33:11 PM
  • #5
    Magic online uses .net framework 4.0.
    Currently playing
    Dega midrange 1-0
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes